{"action":"Upgrade cakephp/cakephp to 4.2.12 or later.","affected":[{"fixed":"4.2.12","introduced":"4.2.0"},{"fixed":"4.3.11","introduced":"4.3.0"},{"fixed":"4.4.10","introduced":"4.4.0"}],"component":"cakephp/cakephp","cve_ids":["CVE-2023-22727"],"ecosystem":"Packagist","epss":0.00898,"exploited":false,"fixed_versions":["4.2.12","4.3.11","4.4.10"],"ghsa_id":"GHSA-6g8q-qfpv-57wp","id":"tcs_01M5KEX18Q66FNEGGHWBD130E1","modified_at":"2026-09-10T03:49:50.877561014Z","published_at":"2023-01-20T17:30:20Z","references":["https://osv.dev/vulnerability/GHSA-6g8q-qfpv-57wp","https://github.com/cakephp/cakephp/security/advisories/GHSA-6g8q-qfpv-57wp","https://nvd.nist.gov/vuln/detail/CVE-2023-22727","https://github.com/cakephp/cakephp/commit/3f463e7084b5a15e67205ced3a622577cca7a239","https://bakery.cakephp.org/2023/01/06/cakephp_4211_4311_4410_released.html","https://github.com/cakephp/cakephp"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-6g8q-qfpv-57wp","url":"https://osv.dev/vulnerability/GHSA-6g8q-qfpv-57wp"}],"summary":"CakePHP Database\\\\Query::offset() and limit() methods are vulnerable to SQL injection"}