{"action":"Upgrade less-openui5 to 0.10.0 or later.","affected":[{"fixed":"0.10.0","introduced":"0"}],"component":"less-openui5","cve_ids":["CVE-2021-21316"],"ecosystem":"npm","epss":0.00988,"exploited":false,"fixed_versions":["0.10.0"],"ghsa_id":"GHSA-3crj-w4f5-gwh4","id":"tcs_01M5KEX1QQVTXD58V8KJ97FPSS","modified_at":"2026-07-08T06:28:29.484614664Z","published_at":"2021-01-29T20:51:37Z","references":["https://osv.dev/vulnerability/GHSA-3crj-w4f5-gwh4","https://github.com/SAP/less-openui5/security/advisories/GHSA-3crj-w4f5-gwh4","https://nvd.nist.gov/vuln/detail/CVE-2021-21316","https://github.com/SAP/less-openui5/commit/c0d3a8572974a20ea6cee42da11c614a54f100e8","https://github.com/SAP/less-openui5/releases/tag/v0.10.0","https://www.npmjs.com/package/less-openui5","http://lesscss.org/usage/#less-options-enable-inline-javascript-deprecated-"],"severity":{"label":"medium","score":6.3},"sources":[{"source":"osv","source_id":"GHSA-3crj-w4f5-gwh4","url":"https://osv.dev/vulnerability/GHSA-3crj-w4f5-gwh4"}],"summary":"Processing untrusted theming resources might execute arbitrary code (ACE)"}