{"action":"Upgrade jupyterlab to 3.6.7 or later.","affected":[{"fixed":"4.0.11","introduced":"4.0.0"},{"fixed":"3.6.7","introduced":"0"}],"component":"jupyterlab","cve_ids":["CVE-2024-22421"],"ecosystem":"PyPI","epss":0.0067,"exploited":false,"fixed_versions":["4.0.11","3.6.7"],"ghsa_id":"GHSA-44cc-43rp-5947","id":"tcs_01M5KEX5W01F1XS9P0AGAGZNNR","modified_at":"2026-09-10T03:50:04.786005565Z","published_at":"2024-01-19T20:28:10Z","references":["https://osv.dev/vulnerability/GHSA-44cc-43rp-5947","https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-44cc-43rp-5947","https://nvd.nist.gov/vuln/detail/CVE-2024-22421","https://github.com/jupyterlab/jupyterlab/commit/19bd9b96cb2e77170a67e43121637d0b5619e8c6","https://github.com/jupyterlab/jupyterlab/commit/1ef7a4fa0202ebdf663e1cc0b45c8813a34a0b96","https://github.com/jupyterlab/jupyterlab/commit/fccd83dc4441da0384ee3fd1322c3b2d9ad4caaa","https://github.com/jupyterlab/jupyterlab","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/UQJKNRDRFMKGVRIYNNN6CKMNJDNYWO2H"],"severity":{"label":"high","score":7.6},"sources":[{"source":"osv","source_id":"GHSA-44cc-43rp-5947","url":"https://osv.dev/vulnerability/GHSA-44cc-43rp-5947"}],"summary":"JupyterLab vulnerable to potential authentication and CSRF tokens leak"}