{"action":"Upgrade tensorflow-gpu to 2.5.3 or later.","affected":[{"fixed":"2.5.3","introduced":"0"},{"fixed":"2.6.3","introduced":"2.6.0"},{"fixed":"2.7.1","introduced":"2.7.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2022-21740"],"ecosystem":"PyPI","epss":0.00794,"exploited":false,"fixed_versions":["2.5.3","2.6.3","2.7.1"],"ghsa_id":"GHSA-44qp-9wwf-734r","id":"tcs_01M5KEX6MHYDQA3AVEG5347WBN","modified_at":"2026-09-10T03:49:11.594037151Z","published_at":"2022-02-09T23:47:14Z","references":["https://osv.dev/vulnerability/GHSA-44qp-9wwf-734r","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-44qp-9wwf-734r","https://nvd.nist.gov/vuln/detail/CVE-2022-21740","https://github.com/tensorflow/tensorflow/commit/2b7100d6cdff36aa21010a82269bc05a6d1cc74a","https://github.com/tensorflow/tensorflow/commit/adbbabdb0d3abb3cdeac69e38a96de1d678b24b3","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2022-64.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2022-119.yaml","https://github.com/tensorflow/tensorflow","https://github.com/tensorflow/tensorflow/blob/5100e359aef5c8021f2e71c7b986420b85ce7b3d/tensorflow/core/kernels/count_ops.cc#L168-L273"],"severity":{"label":"high","score":7.6},"sources":[{"source":"osv","source_id":"GHSA-44qp-9wwf-734r#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-44qp-9wwf-734r"}],"summary":"Heap overflow in Tensorflow"}