{"action":"Upgrade github.com/nats-io/jwt to 1.1.0 or later.","affected":[{"fixed":"1.1.0","introduced":"0"}],"component":"github.com/nats-io/jwt","cve_ids":["CVE-2020-26892"],"ecosystem":"Go","epss":0.02328,"exploited":false,"fixed_versions":["1.1.0"],"ghsa_id":"GHSA-4w5x-x539-ppf5","id":"tcs_01M5KEX8P2S7JNPENTNQ4YJBSR","modified_at":"2026-09-10T03:49:11.546539514Z","published_at":"2022-02-11T23:42:20Z","references":["https://osv.dev/vulnerability/GHSA-4w5x-x539-ppf5","https://github.com/nats-io/jwt/security/advisories/GHSA-4w5x-x539-ppf5","https://nvd.nist.gov/vuln/detail/CVE-2020-26892","https://github.com/nats-io/jwt/commit/e11ce317263cef69619fc1ca743b195d02aa1d8a","https://github.com/nats-io/nats-server/commit/1e08b67f08e18cd844dce833a265aaa72500a12f","https://advisories.nats.io/CVE/CVE-2020-26892.txt","https://github.com/nats-io/jwt","https://github.com/nats-io/nats-server/commits/master","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/VT67XCLIIBYRT762SVFBYFFTQFVSM3SI","https://pkg.go.dev/vuln/GO-2022-0380","https://www.openwall.com/lists/oss-security/2020/11/02/2"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-4w5x-x539-ppf5","url":"https://osv.dev/vulnerability/GHSA-4w5x-x539-ppf5"}],"summary":"Incorrect handling of credential expiry by /nats-io/nats-server"}