{"action":"Upgrade spatie/browsershot to 3.57.4 or later.","affected":[{"fixed":"3.57.4","introduced":"0"}],"component":"spatie/browsershot","cve_ids":["CVE-2022-43984"],"ecosystem":"Packagist","epss":0.00639,"exploited":false,"fixed_versions":["3.57.4"],"ghsa_id":"GHSA-6q49-35h6-rq2p","id":"tcs_01M5KEX94ANKN2YH4FRSXT31XD","modified_at":"2025-04-29T15:57:40.420485Z","published_at":"2022-11-25T18:30:25Z","references":["https://osv.dev/vulnerability/GHSA-6q49-35h6-rq2p","https://nvd.nist.gov/vuln/detail/CVE-2022-43984","https://github.com/spatie/browsershot/commit/554c3e566fde8c47ad1ac9be47eaeb9a84c4dfe2","https://github.com/spatie/browsershot/commit/92cf16fc098211731f80d21687abeafbe2c457ad","https://fluidattacks.com/advisories/malone","https://github.com/spatie/browsershot"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-6q49-35h6-rq2p","url":"https://osv.dev/vulnerability/GHSA-6q49-35h6-rq2p"}],"summary":"Browsershot version 3.57.3 vulnerable to improper input validation"}