{"action":"Upgrade undici to 6.19.2 or later.","affected":[{"fixed":"6.19.2","introduced":"6.14.0"}],"component":"undici","cve_ids":["CVE-2024-38372"],"ecosystem":"npm","epss":0.00467,"exploited":false,"fixed_versions":["6.19.2"],"ghsa_id":"GHSA-3g92-w8c5-73pq","id":"tcs_01M5KEX9RHQHYAKYA5A99DAS6R","modified_at":"2026-09-10T03:50:16.356440101Z","published_at":"2024-07-09T13:32:30Z","references":["https://osv.dev/vulnerability/GHSA-3g92-w8c5-73pq","https://github.com/nodejs/undici/security/advisories/GHSA-3g92-w8c5-73pq","https://nvd.nist.gov/vuln/detail/CVE-2024-38372","https://github.com/nodejs/undici/issues/3328","https://github.com/nodejs/undici/issues/3337","https://github.com/nodejs/undici/pull/3338","https://github.com/nodejs/undici/commit/f979ec3204ca489abf30e7d20e9fee9ea7711d36","https://github.com/nodejs/undici"],"severity":{"label":"low","score":2},"sources":[{"source":"osv","source_id":"GHSA-3g92-w8c5-73pq","url":"https://osv.dev/vulnerability/GHSA-3g92-w8c5-73pq"}],"summary":"Undici vulnerable to data leak when using response.arrayBuffer()"}