{"action":"Upgrade @apollo/query-planner to 2.8.5 or later.","affected":[{"fixed":"2.8.5","introduced":"2.0.0"}],"component":"@apollo/query-planner","cve_ids":["CVE-2024-43414"],"ecosystem":"npm","epss":0.00988,"exploited":false,"fixed_versions":["2.8.5"],"ghsa_id":"GHSA-fmj9-77q8-g6c4","id":"tcs_01M5KEXH4NDEYWRF69TTE821C5","modified_at":"2024-09-13T13:35:59Z","published_at":"2024-08-27T18:14:12Z","references":["https://osv.dev/vulnerability/GHSA-fmj9-77q8-g6c4","https://github.com/apollographql/federation/security/advisories/GHSA-fmj9-77q8-g6c4","https://nvd.nist.gov/vuln/detail/CVE-2024-43414","https://github.com/apollographql/router/commit/e309c9bb5a48c1304ff69c88b7eabdd08c26bf45","https://github.com/apollographql/federation","https://www.apollographql.com/docs/federation/query-plans","https://www.apollographql.com/docs/router/configuration/persisted-queries"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-fmj9-77q8-g6c4#npm/@apollo/query-planner","url":"https://osv.dev/vulnerability/GHSA-fmj9-77q8-g6c4"}],"summary":"Apollo Query Planner and Apollo Gateway may infinitely loop on sufficiently complex queries"}