{"action":"Upgrade rustyscript to 0.6.1 or later.","affected":[{"fixed":"0.6.1","introduced":"0.4.0"}],"component":"rustyscript","cve_ids":[],"ecosystem":"crates.io","exploited":false,"fixed_versions":["0.6.1"],"ghsa_id":"GHSA-fwfx-rrv8-crpf","id":"tcs_01M5KEXNG8F4639J8KG4RYPN8D","modified_at":"2025-10-28T06:29:24.524094Z","published_at":"2024-12-04T18:37:39Z","references":["https://osv.dev/vulnerability/GHSA-fwfx-rrv8-crpf","https://github.com/rscarson/rustyscript/issues/174","https://github.com/rscarson/rustyscripthttps://github.com/rscarson/rustyscript","https://rustsec.org/advisories/RUSTSEC-2024-0405.html"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-fwfx-rrv8-crpf","url":"https://osv.dev/vulnerability/GHSA-fwfx-rrv8-crpf"}],"summary":"op_panic in the base runtime can force a panic in the runtime's containing thread"}