{"action":"Upgrade codeigniter4/framework to 4.1.8 or later.","affected":[{"fixed":"4.1.8","introduced":"0"}],"component":"codeigniter4/framework","cve_ids":["CVE-2022-21715"],"ecosystem":"Packagist","epss":0.01002,"exploited":false,"fixed_versions":["4.1.8"],"ghsa_id":"GHSA-7528-7jg5-6g62","id":"tcs_01M5KEXQ1HQS5CBQ48FEKT2R0J","modified_at":"2024-02-16T08:05:07.804629Z","published_at":"2022-01-27T15:09:00Z","references":["https://osv.dev/vulnerability/GHSA-7528-7jg5-6g62","https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-7528-7jg5-6g62","https://nvd.nist.gov/vuln/detail/CVE-2022-21715","https://github.com/codeigniter4/CodeIgniter4/commit/70d881cf5322b7c32e69516aebd2273ac6a1e8dd","https://codeigniter4.github.io/userguide/incoming/routing.html#use-defined-routes-only","https://github.com/FriendsOfPHP/security-advisories/blob/master/codeigniter4/framework/CVE-2022-21715.yaml","https://github.com/codeigniter4/framework"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-7528-7jg5-6g62","url":"https://osv.dev/vulnerability/GHSA-7528-7jg5-6g62"}],"summary":"Cross-site Scripting Vulnerability in CodeIgniter4"}