{"action":"Upgrade codewhale to 0.8.64 or later.","affected":[{"fixed":"0.8.64","introduced":"0.8.41"}],"component":"codewhale","cve_ids":["CVE-2026-75857"],"ecosystem":"npm","epss":0.00155,"exploited":false,"fixed_versions":["0.8.64"],"ghsa_id":"GHSA-g29h-pfmp-qp9r","id":"tcs_01M5KEXQCT3N74WNE6JX8A6BXT","modified_at":"2026-09-04T19:00:04.276620399Z","published_at":"2026-09-04T18:02:10Z","references":["https://osv.dev/vulnerability/GHSA-g29h-pfmp-qp9r","https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-g29h-pfmp-qp9r","https://nvd.nist.gov/vuln/detail/CVE-2026-75857","https://github.com/Hmbown/CodeWhale/commit/57f3c89471e27ac4032d9791f6885e5d4408c381","https://github.com/Hmbown/CodeWhale","https://www.vulncheck.com/advisories/codewhale-before-privilege-escalation-via-exec-shell-interact"],"severity":{"label":"high","score":7},"sources":[{"source":"osv","source_id":"GHSA-g29h-pfmp-qp9r#npm/codewhale","url":"https://osv.dev/vulnerability/GHSA-g29h-pfmp-qp9r"}],"summary":"CodeWhale: exec_shell_interact sends LLM-controlled input to a running shell without an approval prompt (privilege escalation)"}