{"action":"Upgrade mercurial to 3.8 or later.","affected":[{"fixed":"3.8","introduced":"0"}],"component":"mercurial","cve_ids":["CVE-2016-3105"],"ecosystem":"PyPI","epss":0.02751,"exploited":false,"fixed_versions":["3.8"],"ghsa_id":"GHSA-49cw-434h-qc57","id":"tcs_01M5KEXQFWWP5PQAV49MX9EQ8G","modified_at":"2024-09-30T21:01:05.136792Z","published_at":"2022-05-17T02:37:31Z","references":["https://osv.dev/vulnerability/GHSA-49cw-434h-qc57","https://nvd.nist.gov/vuln/detail/CVE-2016-3105","https://github.com/pypa/advisory-database/tree/main/vulns/mercurial/PYSEC-2016-28.yaml","https://security.gentoo.org/glsa/201612-19","https://selenic.com/hg/rev/a56296f55a5e","https://web.archive.org/web/20200228012056/http://www.securityfocus.com/bid/90536","https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_3.8_.2F_3.8.1_.282016-5-1.29","http://lists.opensuse.org/opensuse-updates/2016-05/msg00082.html","http://www.debian.org/security/2016/dsa-3570","http://www.slackware.com/security/viewer.php?l=slackware-security&y=2016&m=slackware-security.533255"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-49cw-434h-qc57","url":"https://osv.dev/vulnerability/GHSA-49cw-434h-qc57"}],"summary":"Mercurial vulnerable to arbitrary code execution when converting Git repos"}