{"action":"Upgrade packbackbooks/lti-1-3-php-library to 5.0 or later.","affected":[{"fixed":"5.0","introduced":"0"}],"component":"packbackbooks/lti-1-3-php-library","cve_ids":["CVE-2022-31157"],"ecosystem":"Packagist","epss":0.00453,"exploited":false,"fixed_versions":["5.0"],"ghsa_id":"GHSA-768m-5w34-2xf5","id":"tcs_01M5KEXRGQ30YQX5Q7HSZTE6GP","modified_at":"2023-11-08T04:09:28.038385Z","published_at":"2022-07-15T20:55:46Z","references":["https://osv.dev/vulnerability/GHSA-768m-5w34-2xf5","https://github.com/packbackbooks/lti-1-3-php-library/security/advisories/GHSA-768m-5w34-2xf5","https://nvd.nist.gov/vuln/detail/CVE-2022-31157","https://github.com/packbackbooks/lti-1-3-php-library/commit/de19e8a0b28cdc7750fa3ca98471eeed26ba3e57","https://github.com/packbackbooks/lti-1-3-php-library","https://openid.net/specs/openid-connect-core-1_0.html#IDToken"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-768m-5w34-2xf5","url":"https://osv.dev/vulnerability/GHSA-768m-5w34-2xf5"}],"summary":"LTI 1.3 Tool Library's function used to generate random nonces not sufficiently cryptographically complex before v5.0"}