{"action":"Upgrade cbpi4 to 4.4.1.a1 or later.","affected":[{"fixed":"4.4.1.a1","introduced":"4.0.0.58"}],"component":"cbpi4","cve_ids":["CVE-2024-3955"],"ecosystem":"PyPI","epss":0.01149,"exploited":false,"fixed_versions":["4.4.1.a1"],"ghsa_id":"GHSA-4f92-w438-f484","id":"tcs_01M5KEXZ6J5AVD0M4BVH21ZFKZ","modified_at":"2026-06-29T12:26:44.612917942Z","published_at":"2024-05-02T12:30:40Z","references":["https://osv.dev/vulnerability/GHSA-4f92-w438-f484","https://nvd.nist.gov/vuln/detail/CVE-2024-3955","https://github.com/PiBrewing/craftbeerpi4/issues/132","https://cert.pl/en/posts/2024/05/CVE-2024-3955","https://cert.pl/posts/2024/05/CVE-2024-3955","https://github.com/PiBrewing/craftbeerpi4"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-4f92-w438-f484","url":"https://osv.dev/vulnerability/GHSA-4f92-w438-f484"}],"summary":"CraftBeerPi 4 allows arbitrary code execution"}