{"action":"Upgrade tensorflow-gpu to 2.4.4 or later.","affected":[{"fixed":"2.6.1","introduced":"2.6.0"},{"fixed":"2.5.2","introduced":"2.5.0"},{"fixed":"2.4.4","introduced":"0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-41219"],"ecosystem":"PyPI","epss":0.00211,"exploited":false,"fixed_versions":["2.6.1","2.5.2","2.4.4"],"ghsa_id":"GHSA-4f99-p9c2-3j8x","id":"tcs_01M5KEXZSAZ47F811QR04M5QAE","modified_at":"2026-07-08T06:28:51.845924316Z","published_at":"2021-11-10T18:51:51Z","references":["https://osv.dev/vulnerability/GHSA-4f99-p9c2-3j8x","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-4f99-p9c2-3j8x","https://nvd.nist.gov/vuln/detail/CVE-2021-41219","https://github.com/tensorflow/tensorflow/commit/e6cf28c72ba2eb949ca950d834dd6d66bb01cfae","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-628.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-826.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-411.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"GHSA-4f99-p9c2-3j8x#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-4f99-p9c2-3j8x"}],"summary":"Undefined behavior via `nullptr` reference binding in sparse matrix multiplication"}