{"action":"Upgrade tensorflow-cpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-29547"],"ecosystem":"PyPI","epss":0.00189,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-4fg4-p75j-w5xj","id":"tcs_01M5KEY070HE41TG63YHE4ZJK3","modified_at":"2026-07-08T06:28:03.882978167Z","published_at":"2021-05-21T14:23:31Z","references":["https://osv.dev/vulnerability/GHSA-4fg4-p75j-w5xj","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-4fg4-p75j-w5xj","https://nvd.nist.gov/vuln/detail/CVE-2021-29547","https://github.com/tensorflow/tensorflow/commit/d6ed5bcfe1dcab9e85a4d39931bd18d99018e75b","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-475.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-673.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-184.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-4fg4-p75j-w5xj#PyPI/tensorflow-cpu","url":"https://osv.dev/vulnerability/GHSA-4fg4-p75j-w5xj"}],"summary":"Heap out of bounds in `QuantizedBatchNormWithGlobalNormalization`"}