{"action":"Upgrade ckeditor4 to 4.25.0 or later.","affected":[{"fixed":"4.25.0","introduced":"0"}],"component":"ckeditor4","cve_ids":["CVE-2024-43407"],"ecosystem":"npm","epss":0.0045,"exploited":false,"fixed_versions":["4.25.0"],"ghsa_id":"GHSA-7r32-vfj5-c2jv","id":"tcs_01M5KEYBXWWBKTJTBVVSYGCJQY","modified_at":"2025-02-18T19:38:09.951044Z","published_at":"2024-08-21T18:29:15Z","references":["https://osv.dev/vulnerability/GHSA-7r32-vfj5-c2jv","https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-7r32-vfj5-c2jv","https://nvd.nist.gov/vuln/detail/CVE-2024-43407","https://github.com/ckeditor/ckeditor4/commit/71072c9f7f263329841bd38e7e5309074c82ef94","https://github.com/ckeditor/ckeditor4/commit/951e7d75fcbcaa2590b0719fb0bb0dd0539ca6fa","https://github.com/ckeditor/ckeditor4"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-7r32-vfj5-c2jv","url":"https://osv.dev/vulnerability/GHSA-7r32-vfj5-c2jv"}],"summary":"Code Snippet GeSHi plugin in CKEditor 4 has reflected cross-site scripting (XSS) vulnerability"}