{"action":"Upgrade tensorflow-gpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-29616"],"ecosystem":"PyPI","epss":0.00206,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-4hvv-7x94-7vq8","id":"tcs_01M5KEYBZTG962W9RPYWAQGP9X","modified_at":"2026-07-08T06:28:35.712948194Z","published_at":"2021-05-21T14:28:47Z","references":["https://osv.dev/vulnerability/GHSA-4hvv-7x94-7vq8","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-4hvv-7x94-7vq8","https://nvd.nist.gov/vuln/detail/CVE-2021-29616","https://github.com/tensorflow/tensorflow/commit/e6340f0665d53716ef3197ada88936c2a5f7a2d3","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-544.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-742.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-253.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-4hvv-7x94-7vq8#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-4hvv-7x94-7vq8"}],"summary":"Null dereference in Grappler's `TrySimplify`"}