{"action":"Upgrade ejs to 2.5.5 or later.","affected":[{"fixed":"2.5.5","introduced":"0"}],"component":"ejs","cve_ids":["CVE-2017-1000228"],"ecosystem":"npm","epss":0.0638,"exploited":false,"fixed_versions":["2.5.5"],"ghsa_id":"GHSA-3w5v-p54c-f74x","id":"tcs_01M5KEYD6TBS6ZQDWPE1WJ4279","modified_at":"2023-11-08T03:58:44.472757Z","published_at":"2017-11-30T23:15:19Z","references":["https://osv.dev/vulnerability/GHSA-3w5v-p54c-f74x","https://nvd.nist.gov/vuln/detail/CVE-2017-1000228","https://github.com/advisories/GHSA-3w5v-p54c-f74x","https://snyk.io/vuln/npm:ejs:20161128","https://web.archive.org/web/20171123041219/http://www.securityfocus.com/bid/101897"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-3w5v-p54c-f74x","url":"https://osv.dev/vulnerability/GHSA-3w5v-p54c-f74x"}],"summary":"ejs is vulnerable to remote code execution due to weak input validation"}