{"action":"Upgrade aws-advanced-python-wrapper to 1.4.0 or later.","affected":[{"fixed":"1.4.0","introduced":"0"}],"component":"aws-advanced-python-wrapper","cve_ids":["CVE-2025-12967"],"ecosystem":"PyPI","epss":0.00782,"exploited":false,"fixed_versions":["1.4.0"],"ghsa_id":"GHSA-4jvf-wx3f-2x8q","id":"tcs_01M5KEYFR4YZMRQJJ59AXMW224","modified_at":"2026-07-07T17:57:19.328087872Z","published_at":"2025-11-13T22:22:07Z","references":["https://osv.dev/vulnerability/GHSA-4jvf-wx3f-2x8q","https://github.com/aws/aws-advanced-go-wrapper/security/advisories/GHSA-7wq2-32h4-9hc9","https://github.com/aws/aws-advanced-jdbc-wrapper/security/advisories/GHSA-7xw4-g7mm-r4hh","https://github.com/aws/aws-advanced-python-wrapper/security/advisories/GHSA-4jvf-wx3f-2x8q","https://github.com/aws/aws-pgsql-odbc/security/advisories/GHSA-q327-fgm8-7mxf","https://nvd.nist.gov/vuln/detail/CVE-2025-12967","https://github.com/aws/aws-advanced-python-wrapper/pull/1007","https://aws.amazon.com/security/security-bulletins/AWS-2025-028","https://github.com/aws/aws-advanced-python-wrapper","https://github.com/aws/aws-advanced-python-wrapper/releases/tag/1.4.0"],"severity":{"label":"high","score":8},"sources":[{"source":"osv","source_id":"GHSA-4jvf-wx3f-2x8q","url":"https://osv.dev/vulnerability/GHSA-4jvf-wx3f-2x8q"}],"summary":"AWS Advanced Python Wrapper: Privilege Escalation in Aurora PostgreSQL instance"}