{"action":"Upgrade notebook to 7.0.7 or later.","affected":[{"fixed":"7.0.7","introduced":"7.0.0"}],"component":"notebook","cve_ids":["CVE-2024-22420"],"ecosystem":"PyPI","epss":0.00573,"exploited":false,"fixed_versions":["7.0.7"],"ghsa_id":"GHSA-4m77-cmpx-vjc4","id":"tcs_01M5KEYHAZW2WEAWZ8400X84X4","modified_at":"2026-09-10T03:50:04.771668650Z","published_at":"2024-01-19T20:24:09Z","references":["https://osv.dev/vulnerability/GHSA-4m77-cmpx-vjc4","https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-4m77-cmpx-vjc4","https://nvd.nist.gov/vuln/detail/CVE-2024-22420","https://github.com/jupyterlab/jupyterlab/commit/dda0033cd49449572d077bbecd33b18d8d05f48a","https://github.com/jupyterlab/jupyterlab/commit/e1b3aabab603878e46add445a3114e838411d2df","https://github.com/jupyterlab/jupyterlab","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/UQJKNRDRFMKGVRIYNNN6CKMNJDNYWO2H"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-4m77-cmpx-vjc4#PyPI/notebook","url":"https://osv.dev/vulnerability/GHSA-4m77-cmpx-vjc4"}],"summary":"JupyterLab vulnerable to SXSS in Markdown Preview"}