{"action":"Upgrade github.com/argoproj/argo-events to 1.7.1 or later.","affected":[{"fixed":"1.7.1","introduced":"0"}],"component":"github.com/argoproj/argo-events","cve_ids":["CVE-2022-31054"],"ecosystem":"Go","epss":0.01608,"exploited":false,"fixed_versions":["1.7.1"],"ghsa_id":"GHSA-5q86-62xr-3r57","id":"tcs_01M5KEYNHFMF4D0DYMMBJPTZ9J","modified_at":"2024-08-21T15:26:47.686156Z","published_at":"2022-06-17T01:02:56Z","references":["https://osv.dev/vulnerability/GHSA-5q86-62xr-3r57","https://github.com/argoproj/argo-events/security/advisories/GHSA-5q86-62xr-3r57","https://nvd.nist.gov/vuln/detail/CVE-2022-31054","https://github.com/argoproj/argo-events/issues/1946","https://github.com/argoproj/argo-events/pull/1966","https://github.com/argoproj/argo-events/commit/eaabcb6d65022fc34a0cc9ea7f00681abd326b35","https://github.com/argoproj/argo-events"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-5q86-62xr-3r57","url":"https://osv.dev/vulnerability/GHSA-5q86-62xr-3r57"}],"summary":"Uses of deprecated API can be used to cause DoS in user-facing endpoints"}