{"action":"Upgrade jupyter-lsp to 2.2.2 or later.","affected":[{"fixed":"2.2.2","introduced":"0"}],"component":"jupyter-lsp","cve_ids":["CVE-2024-22415"],"ecosystem":"PyPI","epss":0.00491,"exploited":false,"fixed_versions":["2.2.2"],"ghsa_id":"GHSA-4qhp-652w-c22x","id":"tcs_01M5KEYTTH1WK1TWC2W1GJWEXC","modified_at":"2026-09-10T03:50:04.789845699Z","published_at":"2024-01-18T16:12:28Z","references":["https://osv.dev/vulnerability/GHSA-4qhp-652w-c22x","https://github.com/jupyter-lsp/jupyterlab-lsp/security/advisories/GHSA-4qhp-652w-c22x","https://nvd.nist.gov/vuln/detail/CVE-2024-22415","https://github.com/jupyter-lsp/jupyterlab-lsp/commit/4ad12f204ad0b85580fc32137c647baaff044e95","https://github.com/jupyter-lsp/jupyterlab-lsp","https://github.com/jupyter-lsp/jupyterlab-lsp/releases/tag/v5.0.2"],"severity":{"label":"high","score":7.3},"sources":[{"source":"osv","source_id":"GHSA-4qhp-652w-c22x","url":"https://osv.dev/vulnerability/GHSA-4qhp-652w-c22x"}],"summary":"Unsecured endpoints in the jupyter-lsp server extension"}