{"action":"Upgrade ansible to 2.9.27 or later.","affected":[{"fixed":"2.9.27","introduced":"0"}],"component":"ansible","cve_ids":["CVE-2021-3620"],"ecosystem":"PyPI","epss":0.0039,"exploited":false,"fixed_versions":["2.9.27"],"ghsa_id":"GHSA-4r65-35qq-ch8j","id":"tcs_01M5KEYXQ6GH3T0JAGCZ1ZEH6V","modified_at":"2026-02-22T22:55:59.003306Z","published_at":"2022-03-04T00:00:17Z","references":["https://osv.dev/vulnerability/GHSA-4r65-35qq-ch8j","https://nvd.nist.gov/vuln/detail/CVE-2021-3620","https://github.com/ansible/ansible/commit/fe28767970c8ec62aabe493c46b53a5de1e5fac0","https://access.redhat.com/errata/RHSA-2021:3871","https://access.redhat.com/errata/RHSA-2021:3872","https://access.redhat.com/errata/RHSA-2021:3874","https://access.redhat.com/errata/RHSA-2021:4703","https://access.redhat.com/errata/RHSA-2021:4750","https://access.redhat.com/security/cve/CVE-2021-3620","https://bugzilla.redhat.com/show_bug.cgi?id=1975767","https://github.com/advisories/GHSA-4r65-35qq-ch8j","https://github.com/ansible/ansible","https://github.com/ansible/ansible/blob/stable-2.9/changelogs/CHANGELOG-v2.9.rst#security-fixes","https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2022-164.yaml","https://lists.debian.org/debian-lts-announce/2023/12/msg00018.html"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"GHSA-4r65-35qq-ch8j","url":"https://osv.dev/vulnerability/GHSA-4r65-35qq-ch8j"}],"summary":"Ansible discloses sensitive information in traceback error message"}