{"action":"Upgrade moodle/moodle to 3.9.11 or later.","affected":[{"fixed":"3.11.4","introduced":"3.11"},{"fixed":"3.10.8","introduced":"3.10"},{"fixed":"3.9.11","introduced":"3.9"}],"component":"moodle/moodle","cve_ids":["CVE-2021-3943"],"ecosystem":"Packagist","epss":0.02395,"exploited":false,"fixed_versions":["3.11.4","3.10.8","3.9.11"],"ghsa_id":"GHSA-8jhp-2gcr-qw96","id":"tcs_01M5KEZ3MNHJFV9S5FNXVN1ZRZ","modified_at":"2024-02-16T08:24:54.773262Z","published_at":"2021-11-23T00:00:51Z","references":["https://osv.dev/vulnerability/GHSA-8jhp-2gcr-qw96","https://nvd.nist.gov/vuln/detail/CVE-2021-3943","https://github.com/moodle/moodle/commit/58e8ad852f9e75c8158e5bee02c273383f7d9865","https://bugzilla.redhat.com/show_bug.cgi?id=2021963","https://moodle.org/mod/forum/discuss.php?d=429095"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-8jhp-2gcr-qw96","url":"https://osv.dev/vulnerability/GHSA-8jhp-2gcr-qw96"}],"summary":"Moodle vulnerable to RCE via unsafe deserialization"}