{"action":"Upgrade amphp/http-client to 4.4.0 or later.","affected":[{"fixed":"4.4.0","introduced":"4.0.0"}],"component":"amphp/http-client","cve_ids":[],"ecosystem":"Packagist","exploited":false,"fixed_versions":["4.4.0"],"ghsa_id":"GHSA-8jp9-mpv9-98rj","id":"tcs_01M5KEZ47VGJRZV22B2M6NFS4W","modified_at":"2024-11-29T05:28:21.613229Z","published_at":"2024-05-15T17:48:10Z","references":["https://osv.dev/vulnerability/GHSA-8jp9-mpv9-98rj","https://github.com/amphp/http-client/commit/fa7925363e6d5a0d0d337e2e6eb1affb93cf226e","https://github.com/FriendsOfPHP/security-advisories/blob/master/amphp/http-client/2020-06-16.yaml","https://github.com/amphp/http-client","https://github.com/amphp/http-client/releases/tag/v4.4.0"],"severity":{"label":"medium","score":4},"sources":[{"source":"osv","source_id":"GHSA-8jp9-mpv9-98rj","url":"https://osv.dev/vulnerability/GHSA-8jp9-mpv9-98rj"}],"summary":"amphp/http-client Header leakage on cross-domain redirects"}