{"action":"Upgrade tensorflow-cpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-29526"],"ecosystem":"PyPI","epss":0.00198,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-4vf2-4xcg-65cx","id":"tcs_01M5KEZ4GSVWMRQFJAX8XV9D9B","modified_at":"2026-07-08T06:29:03.981132030Z","published_at":"2021-05-21T14:21:55Z","references":["https://osv.dev/vulnerability/GHSA-4vf2-4xcg-65cx","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-4vf2-4xcg-65cx","https://nvd.nist.gov/vuln/detail/CVE-2021-29526","https://github.com/tensorflow/tensorflow/commit/b12aa1d44352de21d1a6faaf04172d8c2508b42b","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-454.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-652.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-163.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-4vf2-4xcg-65cx#PyPI/tensorflow-cpu","url":"https://osv.dev/vulnerability/GHSA-4vf2-4xcg-65cx"}],"summary":"Division by 0 in `Conv2D`"}