{"action":"Upgrade openapi-python-client to 0.29.1 or later.","affected":[{"fixed":"0.29.1","introduced":"0"}],"component":"openapi-python-client","cve_ids":["CVE-2026-105801"],"ecosystem":"PyPI","epss":0.00139,"exploited":false,"fixed_versions":["0.29.1"],"ghsa_id":"GHSA-5293-mq8x-g3xj","id":"tcs_01M5KEZJE63EF6A7WWBKWBZV1E","modified_at":"2026-10-15T14:55:35.768688332Z","published_at":"2026-10-06T15:32:53Z","references":["https://osv.dev/vulnerability/GHSA-5293-mq8x-g3xj","https://github.com/openapi-generators/openapi-python-client/security/advisories/GHSA-5293-mq8x-g3xj","https://nvd.nist.gov/vuln/detail/CVE-2026-105801","https://github.com/openapi-generators/openapi-python-client/pull/1483","https://github.com/openapi-generators/openapi-python-client/commit/1c99af478892e5bbe6583b92acba431c9dec9186","https://github.com/openapi-generators/openapi-python-client","https://github.com/openapi-generators/openapi-python-client/releases/tag/v0.29.1"],"severity":{"label":"high","score":8.4},"sources":[{"source":"osv","source_id":"GHSA-5293-mq8x-g3xj","url":"https://osv.dev/vulnerability/GHSA-5293-mq8x-g3xj"},{"source":"nvd","source_id":"CVE-2026-105801","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-105801"}],"summary":"openapi-python-client: Malicious OpenAPI Documents can cause Arbitrary Code Generation"}