{"action":"Upgrade react-server-dom-webpack to 19.0.5 or later.","affected":[{"fixed":"19.0.5","introduced":"19.0.0"},{"fixed":"19.1.6","introduced":"19.1.0"},{"fixed":"19.2.5","introduced":"19.2.0"}],"component":"react-server-dom-webpack","cve_ids":["CVE-2026-23869"],"ecosystem":"npm","epss":0.01551,"exploited":false,"fixed_versions":["19.0.5","19.1.6","19.2.5"],"ghsa_id":"GHSA-479c-33wc-g2pg","id":"tcs_01M5KEZNVVXVCPXAGWWJCAMAK2","modified_at":"2026-04-10T15:57:10.364539Z","published_at":"2026-04-10T15:35:37Z","references":["https://osv.dev/vulnerability/GHSA-479c-33wc-g2pg","https://github.com/facebook/react/security/advisories/GHSA-479c-33wc-g2pg","https://nvd.nist.gov/vuln/detail/CVE-2026-23869","https://github.com/facebook/react","https://react.dev/blog/2025/12/11/denial-of-service-and-source-code-exposure-in-react-server-components"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-479c-33wc-g2pg#npm/react-server-dom-webpack","url":"https://osv.dev/vulnerability/GHSA-479c-33wc-g2pg"}],"summary":"React Server Components have a Denial of Service Vulnerability"}