{"action":"Upgrade surrealdb to 1.5.4 or later.","affected":[{"fixed":"1.5.4","introduced":"0"},{"fixed":"2.0.0-alpha.6","introduced":"2.0.0-alpha.1"}],"component":"surrealdb","cve_ids":["CVE-2024-58363"],"ecosystem":"crates.io","epss":0.00343,"exploited":false,"fixed_versions":["1.5.4","2.0.0-alpha.6"],"ghsa_id":"GHSA-gh9f-6xm2-c4j2","id":"tcs_01M5KEZZJ9KB21J73TWZ61WSCE","modified_at":"2026-07-19T03:56:46.693762891Z","published_at":"2024-07-11T13:19:19Z","references":["https://osv.dev/vulnerability/GHSA-gh9f-6xm2-c4j2","https://github.com/surrealdb/surrealdb/security/advisories/GHSA-gh9f-6xm2-c4j2","https://github.com/surrealdb/surrealdb/pull/4335","https://github.com/surrealdb/surrealdb/commit/492f8378d57968dbdf5e63fad41b6ff59bba0b80","https://github.com/surrealdb/surrealdb"],"severity":{"label":"medium","score":6.3},"sources":[{"source":"osv","source_id":"GHSA-gh9f-6xm2-c4j2","url":"https://osv.dev/vulnerability/GHSA-gh9f-6xm2-c4j2"}],"summary":"SurrealDB vulnerable to Improper Authentication when Changing Databases as Scope User"}