{"action":"Upgrade github.com/codenotary/immudb to 1.4.1 or later.","affected":[{"fixed":"1.4.1","introduced":"0"}],"component":"github.com/codenotary/immudb","cve_ids":["CVE-2022-39199"],"ecosystem":"Go","epss":0.00283,"exploited":false,"fixed_versions":["1.4.1"],"ghsa_id":"GHSA-6cqj-6969-p57x","id":"tcs_01M5KF001S1QYN5SRZQBDCPSH4","modified_at":"2023-11-08T04:10:14.687054Z","published_at":"2022-11-21T20:38:51Z","references":["https://osv.dev/vulnerability/GHSA-6cqj-6969-p57x","https://github.com/codenotary/immudb/security/advisories/GHSA-6cqj-6969-p57x","https://nvd.nist.gov/vuln/detail/CVE-2022-39199","https://github.com/codenotary/immudb/commit/cade04756ff3f0a3b9e8d24149062744574adf5d","https://github.com/codenotary/immudb","https://github.com/codenotary/immudb/releases/tag/v1.4.1","https://pkg.go.dev/vuln/GO-2022-1118"],"severity":{"label":"medium","score":5.8},"sources":[{"source":"osv","source_id":"GHSA-6cqj-6969-p57x","url":"https://osv.dev/vulnerability/GHSA-6cqj-6969-p57x"}],"summary":"Lack of proper validation of server UUID can be used by the server to trick the client to accept invalid proofs"}