{"action":"Upgrade openclaw to 2026.4.8 or later.","affected":[{"fixed":"2026.4.8","introduced":"0"}],"component":"openclaw","cve_ids":["CVE-2026-42429"],"ecosystem":"npm","epss":0.00239,"exploited":false,"fixed_versions":["2026.4.8"],"ghsa_id":"GHSA-4f8g-77mw-3rxc","id":"tcs_01M5KF05Q5GQCPSVYHHYVS5FF6","modified_at":"2026-06-08T23:30:14.403222033Z","published_at":"2026-04-09T17:36:53Z","references":["https://osv.dev/vulnerability/GHSA-4f8g-77mw-3rxc","https://github.com/openclaw/openclaw/security/advisories/GHSA-4f8g-77mw-3rxc","https://nvd.nist.gov/vuln/detail/CVE-2026-42429","https://github.com/openclaw/openclaw/commit/d7c3210cd6f5fdfdc1beff4c9541673e814354d5","https://github.com/openclaw/openclaw","https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-gateway-plugin-http-authentication"],"severity":{"label":"high","score":7.1},"sources":[{"source":"osv","source_id":"GHSA-4f8g-77mw-3rxc","url":"https://osv.dev/vulnerability/GHSA-4f8g-77mw-3rxc"}],"summary":"OpenClaw: Gateway plugin HTTP `auth: gateway` widens identity-bearing `operator.read` requests into runtime `operator.write`"}