{"action":"Upgrade deepseek-tui to 0.8.41 or later.","affected":[{"fixed":"0.8.41","introduced":"0.8.6"}],"component":"deepseek-tui","cve_ids":["CVE-2026-75911"],"ecosystem":"npm","epss":0.00246,"exploited":false,"fixed_versions":["0.8.41"],"ghsa_id":"GHSA-gx45-xrj5-g6c4","id":"tcs_01M5KF06JR9GWPHPTJKSJ5E3QK","modified_at":"2026-09-04T19:00:05.295715565Z","published_at":"2026-09-04T18:14:09Z","references":["https://osv.dev/vulnerability/GHSA-gx45-xrj5-g6c4","https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-gx45-xrj5-g6c4","https://nvd.nist.gov/vuln/detail/CVE-2026-75911","https://github.com/Hmbown/CodeWhale/commit/43563356b98c6b993085554da82e77370160a31c","https://github.com/Hmbown/CodeWhale","https://www.vulncheck.com/advisories/codewhale-before-remote-code-execution-via-allow-shell"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"GHSA-gx45-xrj5-g6c4#npm/deepseek-tui","url":"https://osv.dev/vulnerability/GHSA-gx45-xrj5-g6c4"}],"summary":"CodeWhale: Project config `allow_shell` override enables arbitrary shell command execution via cloned repository"}