{"action":"Upgrade ckeditor4 to 4.18.0 or later.","affected":[{"fixed":"4.18.0","introduced":"0"}],"component":"ckeditor4","cve_ids":["CVE-2022-24728","CVE-2022-24729"],"ecosystem":"npm","epss":0.01203,"exploited":false,"fixed_versions":["4.18.0"],"ghsa_id":"GHSA-4fc4-4p5g-6w89","id":"tcs_01M5KF06ZHFBT56D6X9S1BDXHJ","modified_at":"2025-12-10T23:41:01.388999Z","published_at":"2022-03-16T22:47:55Z","references":["https://osv.dev/vulnerability/GHSA-4fc4-4p5g-6w89","https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-4fc4-4p5g-6w89","https://nvd.nist.gov/vuln/detail/CVE-2022-24728","https://github.com/ckeditor/ckeditor4/commit/d158413449692d920a778503502dcb22881bc949","https://ckeditor.com/cke4/release/CKEditor-4.18.0","https://github.com/ckeditor/ckeditor4","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/VR76VBN5GW5QUBJFHVXRX36UZ6YTCMW6","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WOZGMCYDB2OKKULFXZKM6V7JJW4ZZHJP","https://securitylab.github.com/advisories/GHSL-2022-009_ckeditor4","https://www.drupal.org/sa-core-2022-005","https://www.oracle.com/security-alerts/cpujul2022.html"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-4fc4-4p5g-6w89","url":"https://osv.dev/vulnerability/GHSA-4fc4-4p5g-6w89"}],"summary":"Cross-site Scripting in CKEditor4"}