{"action":"Upgrade moodle/moodle to 4.1.10 or later.","affected":[{"fixed":"4.3.4","introduced":"4.3.0"},{"fixed":"4.2.7","introduced":"4.2.0"},{"fixed":"4.1.10","introduced":"0"}],"component":"moodle/moodle","cve_ids":["CVE-2024-33997"],"ecosystem":"Packagist","epss":0.00374,"exploited":false,"fixed_versions":["4.3.4","4.2.7","4.1.10"],"ghsa_id":"GHSA-9qgq-93c7-9hm4","id":"tcs_01M5KF082A652TZMKHP6032CSE","modified_at":"2025-05-31T06:27:10.298462Z","published_at":"2024-05-31T21:30:52Z","references":["https://osv.dev/vulnerability/GHSA-9qgq-93c7-9hm4","https://nvd.nist.gov/vuln/detail/CVE-2024-33997","https://github.com/moodle/moodle/commit/25b1b643c873f6d83ae61903012896b2811fa3bb","https://github.com/moodle/moodle","https://moodle.org/mod/forum/discuss.php?d=458385","http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-81352"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-9qgq-93c7-9hm4","url":"https://osv.dev/vulnerability/GHSA-9qgq-93c7-9hm4"}],"summary":"Moodle stored Cross-site Scripting (XSS)"}