{"action":"Upgrade pyspark to 3.2.2 or later.","affected":[{"fixed":"3.2.2","introduced":"3.1.1"}],"component":"pyspark","cve_ids":["CVE-2023-32007"],"ecosystem":"PyPI","epss":0.75955,"exploited":false,"fixed_versions":["3.2.2"],"ghsa_id":"GHSA-59hw-j9g6-mfg3","id":"tcs_01M5KF0JJV5SCZ324FZGMSWQWR","modified_at":"2026-06-09T13:04:11Z","published_at":"2023-05-02T09:30:17Z","references":["https://osv.dev/vulnerability/GHSA-59hw-j9g6-mfg3","https://nvd.nist.gov/vuln/detail/CVE-2023-32007","https://github.com/apache/spark","https://github.com/pypa/advisory-database/tree/main/vulns/pyspark/PYSEC-2023-72.yaml","https://lists.apache.org/thread/poxgnxhhnzz735kr1wos366l5vdbb0nv","https://spark.apache.org/security.html","https://www.cve.org/CVERecord?id=CVE-2022-33891","https://www.openwall.com/lists/oss-security/2023/05/02/1","http://www.openwall.com/lists/oss-security/2023/05/02/1"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-59hw-j9g6-mfg3","url":"https://osv.dev/vulnerability/GHSA-59hw-j9g6-mfg3"}],"summary":"Apache Spark UI vulnerable to Command Injection"}