{"action":"Upgrade tensorflow-gpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-29559"],"ecosystem":"PyPI","epss":0.00198,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-59q2-x2qc-4c97","id":"tcs_01M5KF0KPKQMXRQ0VKHN3XBA0E","modified_at":"2026-07-08T06:29:33.206864837Z","published_at":"2021-05-21T14:24:54Z","references":["https://osv.dev/vulnerability/GHSA-59q2-x2qc-4c97","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-59q2-x2qc-4c97","https://nvd.nist.gov/vuln/detail/CVE-2021-29559","https://github.com/tensorflow/tensorflow/commit/51300ba1cc2f487aefec6e6631fef03b0e08b298","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-487.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-685.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-196.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-59q2-x2qc-4c97#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-59q2-x2qc-4c97"}],"summary":"Heap OOB access in unicode ops"}