{"action":"Upgrade node-opcua to 2.74.0 or later.","affected":[{"fixed":"2.74.0","introduced":"0"}],"component":"node-opcua","cve_ids":["CVE-2022-21208"],"ecosystem":"npm","epss":0.01461,"exploited":false,"fixed_versions":["2.74.0"],"ghsa_id":"GHSA-4hr4-pjjh-2q2w","id":"tcs_01M5KF0MFR4ZZXHB41PSJ82AEC","modified_at":"2023-11-08T04:08:04.902396Z","published_at":"2022-08-24T00:00:31Z","references":["https://osv.dev/vulnerability/GHSA-4hr4-pjjh-2q2w","https://nvd.nist.gov/vuln/detail/CVE-2022-21208","https://github.com/node-opcua/node-opcua/pull/1149","https://github.com/node-opcua/node-opcua/commit/33ca3bab4ab781392a2f8d8f5a14de9a0aa0e410","https://github.com/node-opcua/node-opcua/commit/dbcb5d5191118c22ee9c89332a94b94e6553d76b","https://github.com/node-opcua/node-opcua","https://security.snyk.io/vuln/SNYK-JS-NODEOPCUA-2988723"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-4hr4-pjjh-2q2w","url":"https://osv.dev/vulnerability/GHSA-4hr4-pjjh-2q2w"}],"summary":"Uncontrolled Resource Consumption in node-opcua"}