{"action":"Upgrade xgrammar to 0.1.21 or later.","affected":[{"fixed":"0.1.21","introduced":"0"}],"component":"xgrammar","cve_ids":["CVE-2025-57809"],"ecosystem":"PyPI","epss":0.00485,"exploited":false,"fixed_versions":["0.1.21"],"ghsa_id":"GHSA-5cmr-4px5-23pc","id":"tcs_01M5KF0Q18SR9GZEN709KT2TDH","modified_at":"2026-09-10T03:50:26.791886216Z","published_at":"2025-08-25T20:43:45Z","references":["https://osv.dev/vulnerability/GHSA-5cmr-4px5-23pc","https://github.com/mlc-ai/xgrammar/security/advisories/GHSA-5cmr-4px5-23pc","https://nvd.nist.gov/vuln/detail/CVE-2025-57809","https://github.com/mlc-ai/xgrammar/issues/250","https://github.com/mlc-ai/xgrammar/commit/b943feacb5a1caf4d39de8ec3bf7c7ce066dcee5","https://github.com/mlc-ai/xgrammar"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-5cmr-4px5-23pc","url":"https://osv.dev/vulnerability/GHSA-5cmr-4px5-23pc"}],"summary":"XGrammar affected by Denial of Service by infinite recursion grammars"}