{"action":"Upgrade tensorflow to 2.5.3 or later.","affected":[{"fixed":"2.5.3","introduced":"0"},{"fixed":"2.6.3","introduced":"2.6.0"},{"fixed":"2.7.1","introduced":"2.7.0"}],"component":"tensorflow","cve_ids":["CVE-2022-23579"],"ecosystem":"PyPI","epss":0.00828,"exploited":false,"fixed_versions":["2.5.3","2.6.3","2.7.1"],"ghsa_id":"GHSA-5f2r-qp73-37mr","id":"tcs_01M5KF0SEHENT8AZM297M64VRP","modified_at":"2026-07-13T16:43:20.590351641Z","published_at":"2022-02-10T00:33:29Z","references":["https://osv.dev/vulnerability/GHSA-5f2r-qp73-37mr","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-5f2r-qp73-37mr","https://nvd.nist.gov/vuln/detail/CVE-2022-23579","https://github.com/tensorflow/tensorflow/commit/92dba16749fae36c246bec3f9ba474d9ddeb7662","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2022-88.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2022-143.yaml","https://github.com/tensorflow/tensorflow","https://github.com/tensorflow/tensorflow/blob/a1320ec1eac186da1d03f033109191f715b2b130/tensorflow/core/grappler/optimizers/dependency_optimizer.cc#L59-L98"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-5f2r-qp73-37mr","url":"https://osv.dev/vulnerability/GHSA-5f2r-qp73-37mr"}],"summary":"`CHECK`-failures during Grappler's `SafeToRemoveIdentity` in Tensorflow"}