{"action":"Upgrade knex to 2.4.0 or later.","affected":[{"fixed":"2.4.0","introduced":"0"}],"component":"knex","cve_ids":["CVE-2016-20018"],"ecosystem":"npm","epss":0.01117,"exploited":false,"fixed_versions":["2.4.0"],"ghsa_id":"GHSA-4jv9-3563-23j3","id":"tcs_01M5KF0VHHD7KXWN9F769WMRTX","modified_at":"2023-11-08T03:58:23.366089Z","published_at":"2022-12-19T09:30:23Z","references":["https://osv.dev/vulnerability/GHSA-4jv9-3563-23j3","https://nvd.nist.gov/vuln/detail/CVE-2016-20018","https://github.com/knex/knex/issues/1227","https://github.com/knex/knex/pull/5417","https://github.com/knex/knex/commit/e145322da92749be7749f9ade5b5f5a66d6586a4","https://github.com/knex/knex","https://github.com/knex/knex/releases/tag/2.4.0","https://www.ghostccamm.com/blog/knex_sqli"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-4jv9-3563-23j3","url":"https://osv.dev/vulnerability/GHSA-4jv9-3563-23j3"}],"summary":"Knex.js has a limited SQL injection vulnerability"}