{"action":"Upgrade chriskacerguis/codeigniter-restserver to 2.7.2 or later.","affected":[{"fixed":"2.7.2","introduced":"0"}],"component":"chriskacerguis/codeigniter-restserver","cve_ids":["CVE-2015-3907"],"ecosystem":"Packagist","epss":0.01642,"exploited":false,"fixed_versions":["2.7.2"],"ghsa_id":"GHSA-cc7g-9pcj-7gwm","id":"tcs_01M5KF0W69C1KSGNSPPTAZJW6G","modified_at":"2023-12-07T21:27:33Z","published_at":"2022-05-24T16:49:26Z","references":["https://osv.dev/vulnerability/GHSA-cc7g-9pcj-7gwm","https://nvd.nist.gov/vuln/detail/CVE-2015-3907","https://github.com/chriskacerguis/codeigniter-restserver/issues/461","https://github.com/chriskacerguis/codeigniter-restserver/commit/852740e7c636e4f44b3a8e3afc15155795e22c9b","https://github.com/chriskacerguis/codeigniter-restserver","https://kb.hitcon.org/post/127839729207/codeigniter-rest-server-module-xxe-cve-2015-3907"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-cc7g-9pcj-7gwm","url":"https://osv.dev/vulnerability/GHSA-cc7g-9pcj-7gwm"}],"summary":"CodeIgniter Rest Server XXE Vulnerability"}