{"action":"Upgrade github.com/hyperledger/fabric to 2.2.7 or later.","affected":[{"fixed":"2.2.7","introduced":"0"},{"fixed":"2.4.5","introduced":"2.3.0"}],"component":"github.com/hyperledger/fabric","cve_ids":["CVE-2022-31121"],"ecosystem":"Go","epss":0.02086,"exploited":false,"fixed_versions":["2.2.7","2.4.5"],"ghsa_id":"GHSA-72x4-cq6r-jp4p","id":"tcs_01M5KF16R6W0JGTVJBJY8PYAS1","modified_at":"2024-07-18T20:11:50.393825Z","published_at":"2022-07-08T17:06:39Z","references":["https://osv.dev/vulnerability/GHSA-72x4-cq6r-jp4p","https://github.com/hyperledger/fabric/security/advisories/GHSA-72x4-cq6r-jp4p","https://nvd.nist.gov/vuln/detail/CVE-2022-31121","https://github.com/hyperledger/fabric/commit/0f18359493bcbd5f9f9d1a9b05adabfe5da23b06","https://github.com/hyperledger/fabric","https://github.com/hyperledger/fabric/releases/tag/v2.2.7","https://github.com/hyperledger/fabric/releases/tag/v2.4.5"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-72x4-cq6r-jp4p","url":"https://osv.dev/vulnerability/GHSA-72x4-cq6r-jp4p"}],"summary":"Hyperledger Fabric vulnerable to Improper Input Validation in orderer/common/cluster consensus request"}