{"action":"Upgrade github.com/containerd/containerd to 1.2.14 or later.","affected":[{"fixed":"1.2.14","introduced":"0"}],"component":"github.com/containerd/containerd","cve_ids":["CVE-2020-15157"],"ecosystem":"Go","epss":0.02299,"exploited":false,"fixed_versions":["1.2.14"],"ghsa_id":"GHSA-742w-89gc-8m9c","id":"tcs_01M5KF18P7NNNWS57J3VHQ1MSH","modified_at":"2026-09-10T03:49:11.641147538Z","published_at":"2022-02-11T23:27:39Z","references":["https://osv.dev/vulnerability/GHSA-742w-89gc-8m9c","https://github.com/containerd/containerd/security/advisories/GHSA-742w-89gc-8m9c","https://nvd.nist.gov/vuln/detail/CVE-2020-15157","https://github.com/containerd/containerd/commit/1ead8d9deb3b175bf40413b8c47b3d19c2262726","https://darkbit.io/blog/cve-2020-15157-containerdrip","https://github.com/containerd/containerd","https://github.com/containerd/containerd/releases/tag/v1.2.14","https://usn.ubuntu.com/4589-1","https://usn.ubuntu.com/4589-2","https://www.debian.org/security/2021/dsa-4865"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-742w-89gc-8m9c","url":"https://osv.dev/vulnerability/GHSA-742w-89gc-8m9c"}],"summary":"containerd v1.2.x can be coerced into leaking credentials during image pull"}