{"action":"Upgrade phpseclib/phpseclib to 1.0.23 or later.","affected":[{"fixed":"2.0.47","introduced":"2.0.0"},{"fixed":"3.0.36","introduced":"3.0.0"},{"fixed":"1.0.23","introduced":"0.1.1"}],"component":"phpseclib/phpseclib","cve_ids":["CVE-2024-27355"],"ecosystem":"Packagist","epss":0.00569,"exploited":false,"fixed_versions":["2.0.47","3.0.36","1.0.23"],"ghsa_id":"GHSA-f2qx-66wf-wvvx","id":"tcs_01M5KF1BQHPWTCFT18H4R4V0N9","modified_at":"2026-05-08T18:41:11.562325Z","published_at":"2026-05-08T18:24:30Z","references":["https://osv.dev/vulnerability/GHSA-f2qx-66wf-wvvx","https://github.com/phpseclib/phpseclib/security/advisories/GHSA-f2qx-66wf-wvvx","https://nvd.nist.gov/vuln/detail/CVE-2024-27355","https://github.com/phpseclib/phpseclib/commit/e32531001b4d62c66c3d824ccef54ffad835eb59","https://gist.github.com/katzj/ee72f3c2a00590812b2ea3c0c8890e0b","https://github.com/FriendsOfPHP/security-advisories/blob/master/phpseclib/phpseclib/CVE-2024-27355.yaml","https://github.com/phpseclib/phpseclib","https://github.com/phpseclib/phpseclib/blob/978d081fe50ff92879c50ff143c62a143edb0117/phpseclib/File/ASN1.php#L1129","https://lists.debian.org/debian-lts-announce/2024/03/msg00002.html","https://lists.debian.org/debian-lts-announce/2024/03/msg00003.html"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-f2qx-66wf-wvvx","url":"https://osv.dev/vulnerability/GHSA-f2qx-66wf-wvvx"}],"summary":"phpseclib guardrails needed on OID length"}