{"action":"Upgrade cfscrape to 1.8.0 or later.","affected":[{"fixed":"1.8.0","introduced":"1.6.6"}],"component":"cfscrape","cve_ids":["CVE-2017-7235"],"ecosystem":"PyPI","epss":0.01548,"exploited":false,"fixed_versions":["1.8.0"],"ghsa_id":"GHSA-5mc5-5j6c-qmf9","id":"tcs_01M5KF1BYRKGQ41V0R4HARXEEK","modified_at":"2024-09-13T14:56:26.825135Z","published_at":"2018-07-13T16:01:01Z","references":["https://osv.dev/vulnerability/GHSA-5mc5-5j6c-qmf9","https://nvd.nist.gov/vuln/detail/CVE-2017-7235","https://github.com/Anorov/cloudflare-scrape/issues/97","https://github.com/Anorov/cloudflare-scrape","https://github.com/Anorov/cloudflare-scrape/releases/tag/1.8.0","https://github.com/advisories/GHSA-5mc5-5j6c-qmf9","https://github.com/pypa/advisory-database/tree/main/vulns/cfscrape/PYSEC-2017-7.yaml","https://web.archive.org/web/20170701161512/http://www.securityfocus.com/bid/97191"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-5mc5-5j6c-qmf9","url":"https://osv.dev/vulnerability/GHSA-5mc5-5j6c-qmf9"}],"summary":"cfscrape Improper Input Validation vulnerability"}