{"action":"Upgrade mysql2 to 3.9.7 or later.","affected":[{"fixed":"3.9.7","introduced":"0"}],"component":"mysql2","cve_ids":["CVE-2024-21511"],"ecosystem":"npm","epss":0.01034,"exploited":false,"fixed_versions":["3.9.7"],"ghsa_id":"GHSA-4rch-2fh8-94vw","id":"tcs_01M5KF1C8ZKHAHSAQRVQAM7A60","modified_at":"2026-09-10T03:50:11.169102793Z","published_at":"2024-04-23T06:30:47Z","references":["https://osv.dev/vulnerability/GHSA-4rch-2fh8-94vw","https://nvd.nist.gov/vuln/detail/CVE-2024-21511","https://github.com/sidorares/node-mysql2/pull/2608","https://github.com/sidorares/node-mysql2/commit/7d4b098c7e29d5a6cb9eac2633bfcc2f0f1db713","https://github.com/sidorares/node-mysql2","https://github.com/sidorares/node-mysql2/releases/tag/v3.9.7","https://security.snyk.io/vuln/SNYK-JS-MYSQL2-6670046"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-4rch-2fh8-94vw","url":"https://osv.dev/vulnerability/GHSA-4rch-2fh8-94vw"}],"summary":"MySQL2 for Node Arbitrary Code Injection"}