{"action":"Upgrade torch to 2.2.0 or later.","affected":[{"fixed":"2.2.0","introduced":"0"}],"component":"torch","cve_ids":["CVE-2024-31580"],"ecosystem":"PyPI","epss":0.00225,"exploited":false,"fixed_versions":["2.2.0"],"ghsa_id":"GHSA-5pcm-hx3q-hm94","id":"tcs_01M5KF1F09CABJGC0RA759HJY0","modified_at":"2026-07-27T12:26:34.306757669Z","published_at":"2024-04-17T21:30:48Z","references":["https://osv.dev/vulnerability/GHSA-5pcm-hx3q-hm94","https://nvd.nist.gov/vuln/detail/CVE-2024-31580","https://github.com/pytorch/pytorch/commit/b5c3a17c2c207ebefcb85043f0cf94be9b2fef81","https://gist.github.com/1047524396/038c78f2f007345e6f497698ace2aa3d","https://github.com/pypa/advisory-database/tree/main/vulns/torch/PYSEC-2024-252.yaml","https://github.com/pytorch/pytorch","https://security.snyk.io/vuln/SNYK-PYTHON-TORCH-6649934"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-5pcm-hx3q-hm94","url":"https://osv.dev/vulnerability/GHSA-5pcm-hx3q-hm94"}],"summary":"PyTorch heap buffer overflow vulnerability"}