{"action":"Upgrade deno to 1.41.0 or later.","affected":[{"fixed":"1.41.0","introduced":"1.32.1"}],"component":"deno","cve_ids":["CVE-2024-27936"],"ecosystem":"crates.io","epss":0.00943,"exploited":false,"fixed_versions":["1.41.0"],"ghsa_id":"GHSA-m4pq-fv2w-6hrw","id":"tcs_01M5KF1F4H10T6XZEVYFW28C6A","modified_at":"2026-09-10T03:50:10.601906622Z","published_at":"2024-03-05T20:54:14Z","references":["https://osv.dev/vulnerability/GHSA-m4pq-fv2w-6hrw","https://github.com/denoland/deno/security/advisories/GHSA-m4pq-fv2w-6hrw","https://nvd.nist.gov/vuln/detail/CVE-2024-27936","https://github.com/denoland/deno/commit/78d430103a8f6931154ddbbe19d36f3b8630286d","https://github.com/denoland/deno/commit/7e6b94231290020b55f1d08fb03ea8132781abc5","https://github.com/denoland/deno"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-m4pq-fv2w-6hrw","url":"https://osv.dev/vulnerability/GHSA-m4pq-fv2w-6hrw"}],"summary":"Deno's deno_runtime vulnerable to interactive permission prompt spoofing via improper ANSI stripping"}