{"action":"Upgrade sagemaker to 3.4.0 or later.","affected":[{"fixed":"3.4.0","introduced":"3.0.0"}],"component":"sagemaker","cve_ids":[],"ecosystem":"PyPI","exploited":false,"fixed_versions":["3.4.0"],"ghsa_id":"GHSA-5r2p-pjr8-7fh7","id":"tcs_01M5KF1M0KGF8JASBKMY3S0KA5","modified_at":"2026-10-02T20:15:05.895004600Z","published_at":"2026-03-05T22:01:09Z","references":["https://osv.dev/vulnerability/GHSA-5r2p-pjr8-7fh7","https://github.com/aws/sagemaker-python-sdk/security/advisories/GHSA-5r2p-pjr8-7fh7","https://github.com/aws/sagemaker-python-sdk/pull/5497","https://github.com/aws/sagemaker-python-sdk/commit/3203e4996219799e7fcad214c7925ffd8594da1f","https://github.com/aws/sagemaker-python-sdk/commit/e706e578519bd9b92ea44b9b15f872eca5e77ea4","https://github.com/aws/sagemaker-python-sdk"],"severity":{"label":"high"},"sources":[{"source":"osv","source_id":"GHSA-5r2p-pjr8-7fh7","url":"https://osv.dev/vulnerability/GHSA-5r2p-pjr8-7fh7"}],"summary":"SageMaker Python SDK replaced eval() with safe parser in JumpStart search functionality"}